Thursday, April 2, 2015

My Arduino 1.6.3 cannot detect port

Just tried the new released Arduino IDE 1.6.3 on Ubuntu Linux 14.04, the first time run is ok.

But after a moment, it cannot detect connected usb port, with error following error. Even after reboot.
~/arduino-1.6.3$ ./arduino
Exception in thread "cc.arduino.packages.discoverers.serial.SerialBoardsLister" java.lang.NullPointerException
 at java.util.TimerThread.mainLoop(

Tried to switch back to Arduino 1.6.0, it can detect usb as normal.

This video show how:

1 comment:

  1. Hi. I saw something peculear happening in arduino-1.8.2, on ubuntu 16.04.02 LTS.
    If I run ./arduino from the arduino home directory, while it gives the exception
    Exception in thread "cc.arduino.packages.discoverers.serial.SerialBoardsLister" java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
    at java.util.LinkedList.checkElementIndex(
    at java.util.LinkedList.get(
    at cc.arduino.packages.discoverers.serial.SerialBoardsLister.retriggerDiscovery(
    at java.util.TimerThread.mainLoop(

    The peculear part is, it gives this exception only once and when the usb device is connected.

    Also if I run the command without the device connected, this error does not show up untill I attach the usb device.

    I have had this problem before, and sometimes it does not happen. Also when it does, my pc becomes useless for arduino for days togather.

    I tried all the tricks.
    Adding user to dialout group,
    running arduino as sudo
    connecting disconnecting the usb port several times
    etc etc